Business Banking > Online Banking > Browser Requirements

BizBanker Browser Requirements

BizBanker is compatible with a number of different operating systems and browsers. Please consult the list below to confirm your system will be supported. If you have any additional questions, please email our Customer Resource Center or call us
at 617-876-5500.

Operating System Apple Safari
Browsers
Microsoft Internet
Explorer Browsers
Mozilla Browsers Google ChromeTM
Windows® XP SP3 N/A 8 Firefox® 20, 25 and higher 31 and higher
Windows 7 64 bit N/A 9, 10 Firefox 25 and higher 31 and higher
Windows 8 64 bit N/A 10 Firefox 25 and higher 31 and higher
Windows 8.1 N/A 11 Firefox 25 and higher 31 and higher
Mac® OS X® 10.7
Lion
Safari® 5, 6 N/A N/A N/A
Mac OS X 10.8 Mountain Lion Safari 6 N/A N/A N/A
Mac OS X 10.9 Mavericks Safari 7 N/A N/A N/A